Lttng 與 Gnome [論壇 - Ubuntu 與 GNOME]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



Lttng 與 Gnome
會員一級
註冊日期:
2011/7/31 12:15
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 34
MP : 4 / 843
EXP: 38
離線
想請問一下,不知道有沒有人試過 lttng 這個東西??
使用 lttng 時需要啟動進入他的核心,但 gnome 就因此進不去了,連原來的也進不去,之前試過 KDE 好像就比較正常些,請問有人遇過這樣的問題嗎 ??

2011/7/31 12:19
應用擴展 工具箱
回覆: Lttng 與 Gnome

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 51322
EXP: 24
離線
1. ubuntu 11.04 ? 10.10 ? 10.04 ? ...
2. LTTng Stable PPA ? / LTTng Experimental PPA ? / LTTng Daily Builds ?
你用哪個版本 ?
the LTTng (Linux Trace Toolkit Next Generation) tracing suite in Ubuntu.

2011/7/31 17:03
應用擴展 工具箱
回覆: Lttng 與 Gnome
會員一級
註冊日期:
2011/7/31 12:15
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 34
MP : 4 / 843
EXP: 38
離線
應該是 Stable PPA 這一個版本

2011/7/31 18:32
應用擴展 工具箱
回覆: Lttng 與 Gnome

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 51322
EXP: 24
離線
1. LTTng Stable PPA 這一個版本已知問題:

1-1. 如果 你是用 ubuntu 10.04 從 LTTng 下載 10.04 版 安裝 會有相容性 問題
The Lucid kernel package is based on Maverick's 2.6.35, you may experience compatibility problems with it (as Lucid uses 2.6.32 by default).

1-2. lttng-agent TCF plugin 目前版本 與 UST 0.12+ 無法配合
The current version of the lttng-agent TCF plugin does not work with UST 0.12+. The userspace trace control tools are currently going through major changes, but remote control will be looked at again once they stabilize.

資料來源:
LTTng Stable PPA

2. 參考文件
使用手冊 / LTTng kernel tracer manual

3. LTTng+LTTV 版本相容表
(其中包含與 linux-kernel 版本相容情況)
(請捲到最下面 看最新版本)
LTTng+LTTV versions compatibility

2011/7/31 19:19
應用擴展 工具箱
回覆: Lttng 與 Gnome
會員一級
註冊日期:
2011/7/31 12:15
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 34
MP : 4 / 843
EXP: 38
離線
感謝你喔,不過舉個比方好了
我現在使用 ubuntu 11.04 來做,而核心應該是 2.6.38,那 LTTng 我只能用0.246嗎?? 還是我0.249也可以用

對喔,剛剛有問到版本,沒回答到,對不起喔,是 11.04 的

2011/7/31 23:21
應用擴展 工具箱
回覆: Lttng 與 Gnome

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 51322
EXP: 24
離線
1. 以下資料來自 3. LTTng+LTTV 版本相容表
1. Linux 2.6.38. (這樣寫可能包含 2.6.38.x ?)
1-1. LTTng 0.246: Linux 2.6.38. (這樣寫可能包含 2.6.38.x ?)
LTTng 0.246 and lttng-modules 0.19.7 support Linux 2.6.38.
1-2. LTTng 0.247:Linux 2.6.38. (這樣寫可能包含 2.6.38.x ?)
LTTng 0.247 and lttng-modules 0.19.8 add back MAYBE_BUILD_BUG_ON specifically for lttng modules and fix a prototype mismatch warning.
1-3. LTTng 0.248:linux-kernel 需 2.6.38.2 以上
LTTng 0.248 supports kernel 2.6.38.2, fixes a quilt vs git lockdep patch hunk error (all quilt patches refreshed), merges OMAP4 trace clock fix.
lttng-modules 0.19.9 is a bugfix release, fixes incorrect handling of disabled channels.
1-4. LTTng 0.249:linux-kernel 需 2.6.38.6 以上
lttng-modules 0.19.10 and LTTng 0.249 add dup() instrumentation and fixes socket_sendmsg probe name typo. LTTng 0.249 is based on kernel 2.6.38.6.

2. 快速入門教學:
This page gives you quick instruction on how to get your first trace
Installation tutorial for LTTng and LTTV
Installation tutorial for UST

2011/8/1 7:24
應用擴展 工具箱
回覆: Lttng 與 Gnome
會員一級
註冊日期:
2011/7/31 12:15
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 34
MP : 4 / 843
EXP: 38
離線
我大概知道是哪裡出錯了...

我在安裝 linux-image-2.6.XX 的時候,有出現 fglrx 錯誤,我想大概是顯卡驅動程式的問題

隨後我更新了系統,大概就沒有問題了

(我在想,可能是因為 xorg 的問題,開機時卡在某個地方)

2011/8/12 0:32
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.