gcin 更新後 anthy日文輸入法不能用 [論壇 - Ubuntu 與中文]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



gcin 更新後 anthy日文輸入法不能用
會員二級
註冊日期:
2011/5/9 10:56
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 140
MP : 20 / 3861
EXP: 62
離線
最近幾天發現的問題

我的 gcin 更新後

其他輸入法都能正常加入 ctrl-shift 循環切換

惟獨 anthy日文輸入法不能用

有人跟我發生同樣的問題嗎?

目前版本 : gcin 1.6.5 on Ubuntu 10.10

gcon 使用來源:
deb http://debian.luna.com.tw/maverick ./
deb-src http://debian.luna.com.tw ./

2011/9/2 14:26
Linux is for people who want to know why it works.
Mac is for people who don't want to know why it works.
DOS is for people who want to know why it does not work.
Windows is for people who don't want to know why it does not work.
應用擴展 工具箱
回覆: gcin 更新後 anthy日文輸入法不能用

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 55537
EXP: 24
離線

2011/9/2 17:39
應用擴展 工具箱
回覆: gcin 更新後 anthy日文輸入法不能用
會員二級
註冊日期:
2011/5/9 10:56
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 140
MP : 20 / 3861
EXP: 62
離線
有點不太確定

他說 anthy-module.so chewing-module.so 這兩個共享庫搬家了

可是我的注音是可以開啟的 #雖然我是詞音user XD

好像只有 anthy 有問題

而且我的/usr/lib/gcin 只有下面3個檔案耶

libgcin-im-client.so libgcin-im-client.so.1 libgcin-im-client.so.1.2.3

locate 了一下,跟 anthy 可能有關係的檔案只有:

/usr/lib/libanthy.so.0
/usr/lib/libanthy.so.0.1.0
/usr/lib/libanthydic.so.0
/usr/lib/libanthydic.so.0.1.0
/usr/lib/libanthyinput.so.0
/usr/lib/libanthyinput.so.0.0.0

沒有找到 anthy-module.so

2011/9/3 3:28
Linux is for people who want to know why it works.
Mac is for people who don't want to know why it works.
DOS is for people who want to know why it does not work.
Windows is for people who don't want to know why it does not work.
應用擴展 工具箱
回覆: gcin 更新後 anthy日文輸入法不能用

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 55537
EXP: 24
離線
你有沒有使用 ibus 輸入框架 或稱 輸入平臺 (ubuntu 預裝)再選裝 gcin ?
還是 把 ibus 移除 另外 安裝 gcin ?

把這六個檔案
/usr/lib/libanthy.so.0
/usr/lib/libanthy.so.0.1.0
/usr/lib/libanthydic.so.0
/usr/lib/libanthydic.so.0.1.0
/usr/lib/libanthyinput.so.0
/usr/lib/libanthyinput.so.0.0.0
copy 一份 到 /usr/lib/gcin
然後 關閉 gcin 再重新啓動 gcin 試試看

2011/9/3 6:00
應用擴展 工具箱
回覆: gcin 更新後 anthy日文輸入法不能用
會員二級
註冊日期:
2011/5/9 10:56
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 140
MP : 20 / 3861
EXP: 62
離線
抱歉這幾天時間不多,現在才看到文章

我已經照您的方法試過了

依舊不能開啟gcin

ibus 沒動過,當時是直接 apt-get 下來再選 gcin 當輸入法

以前日文輸入是能用的,更新後就失效了

2011/9/5 1:52
Linux is for people who want to know why it works.
Mac is for people who don't want to know why it works.
DOS is for people who want to know why it does not work.
Windows is for people who don't want to know why it does not work.
應用擴展 工具箱
回覆: gcin 更新後 anthy日文輸入法不能用

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 55537
EXP: 24
離線
檢查一下 libanthy-dev 套件有沒有安裝

資料來源
若想用 anthy 日文輸入請安裝 libanthy-dev

2011/9/5 8:21
應用擴展 工具箱
回覆: gcin 更新後 anthy日文輸入法不能用
會員二級
註冊日期:
2011/5/9 10:56
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 140
MP : 20 / 3861
EXP: 62
離線
sudo apt-get install libanthy-dev

裝了這個套件但是還是不能用 = =a

=======================
參考了

http://debian.luna.com.tw/

發現我 gcin-anthy 這個套件沒裝到

裝上後就能用了

あいうえお

========================

之前升級前沒這個問題,我猜是升級時把這個套件移除掉了 = =?

2011/9/6 11:36
Linux is for people who want to know why it works.
Mac is for people who don't want to know why it works.
DOS is for people who want to know why it does not work.
Windows is for people who don't want to know why it does not work.
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.