套件版本的問題 [論壇 - 新手村]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



套件版本的問題
會員一級
註冊日期:
2012/2/16 23:04
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 21
MP : 3 / 673
EXP: 86
離線
各位大大好

我想請問在ubuntu 裡安裝套件的方法是
sudo apt-get isntall 套件名稱

那我想請問用這樣方式安裝的套件會是最新的嬤
還是要用最新的一定要去官網下載套件然後自己再make install

如果apt-get install的套件不是最新的
有什麼方法可以讓他自動去更新的嗎

還有套件的版本有什麼指令可以看的嗎

2012/2/18 10:48
應用擴展 工具箱
回覆: 套件版本的問題

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 65765
EXP: 24
離線

2012/2/18 11:08
應用擴展 工具箱
回覆: 套件版本的問題
版主
註冊日期:
2008/7/14 0:03
來自 螢幕的另一端
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 33
HP : 0 / 806
MP : 508 / 33479
EXP: 24
離線
https://wiki.ubuntu.com/UbuntuBackports

採用了 backports 的來源,所以會一併更新其它的套件,若你不想更新其它套件的話,可在更新管理員列表裡把不想更新的套件打勾取消,待裝完新版的 gnucash 之後,再去 /etc/apt/sources.list 裡把這個來源給註解掉。

何謂 backports ?
就是舊版的ubuntu作業系統裡包的套件都是舊的套件和軟體包,這些套件與軟體包經常會有新版的出來, backports 就是整理好這些較新版的軟體與套件放在一起,你只要加入 backports 的來源後,就可輕鬆的用一行指令來安裝新版的軟體,而不用再自己下載新版的軟體、還要重新編譯、解決套件衝突等問題。 backports 是 ubuntu 官方維護的套件庫,所以可以放心的使用吧!


backports 也沒有全部都是最新的,但大多比較熱門的軟體、套件都會有新的版本,若剛好你要的軟體 backports 裡沒有最新的版本的話,那能你就要採用其它方法了。

make install
or
http://www.getdeb.net/welcome/
or
ppa 源
http://ubuntu543.blogspot.com/2010/09/getdeb-ppa.html

2012/2/18 11:10
應用擴展 工具箱
回覆: 套件版本的問題
會員一級
註冊日期:
2012/2/16 23:04
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 21
MP : 3 / 673
EXP: 86
離線
那如果我已經sudo apt-get install 套件了

那之後我在自己make isntall同樣套件的話
那原本的套件會怎麼樣呢

2012/2/18 13:59
應用擴展 工具箱
回覆: 套件版本的問題

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 65765
EXP: 24
離線
那之後我在自己make isntall同樣套件的話

如果 你是指 類似 checkinstall -D make install 這樣的指令
他只是 打包好 *.deb 套件 放在 你所指定的目錄

只有 sudo dpkg -i *.deb
才會 去檢查 你的 安裝套件資料庫 有沒有 相同 名稱套件 已安裝
如果你要安裝的版本比較新
他才會去尋找 相依套件 是否齊全
然後 把情況 跟你 彙報 要你確認 裝不裝

也就是說 make install 只是 打包好 放在那裏

2012/2/18 14:31
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.