安裝gcin遇到的問題 [論壇 - Ubuntu 與中文]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 »


安裝gcin遇到的問題

註冊日期:
2007/7/3 14:49
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
大家好,我是linux的新手啊
昨天安裝gcin時,出現了幾個錯誤
但新手看不懂訊息,問朋友說是我安裝的版本太舊所造成
但還不太了要如何更新這些套件的版本
下面是我把圖抓下來

還請高手指點一下

2007/7/3 14:59
應用擴展 工具箱
回復: 安裝gcin遇到的問題
會員二級
註冊日期:
2007/6/25 0:58
來自 打狗
所屬群組:
已註冊使用者
等級: 7
HP : 0 / 163
MP : 24 / 7376
EXP: 53
離線
您是用LiveCD的方式開機,還是己經安裝進入硬碟了呢?
另外您使用的版本是那一個?

2007/7/3 17:11
Ubuntu -「以人道待人」
應用擴展 工具箱
回復: 安裝gcin遇到的問題
Anon:…
請加上sudo,新增移除套件需要root權限

2007/7/3 17:54 | 93c14 6df45 d6219 00255
應用擴展 工具箱
回復: 安裝gcin遇到的問題
回復: 安裝gcin遇到的問題
Anon:回復: 安裝gcin遇到的問題
gcin 官方網站的是給 Debian 用的。

Ubuntu 安裝官方的 gcin 1.3.3 就好

Feisty (7.04) 已內建
Edgy (6.10) 要編輯 /etc/apt/sources.list 啟用 edgy-backports
Dapper (6.06) 要編輯 /etc/apt/sources.list 啟用 dapper-backports

2007/7/3 18:10 | 77ea3 6d875 4ab4d 7d8b7
應用擴展 工具箱
whk
回復: 安裝gcin遇到的問題
Anon:whk
我已經裝在硬碟裡了,安裝的是7.04版,也使用了su 變成root帳號

2007/7/3 21:38 | 73296 056b4 9faab b731f
應用擴展 工具箱
回復: 安裝gcin遇到的問題

註冊日期:
2007/7/3 14:49
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
好吧,我試了gcin1.3.3 tar.bz2
結果在 ./configure 時發生 錯誤
訊息如下
./configure
prefix: /usr/local
.... Testing gtk+-2.0 : Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
gtk+-2.0 or above required --cflags

但是我用synaptic 並沒有找到gtk+-2.0之類的檔案
還請高手幫個忙

另一說 …
我的環境的MENU是英文,但內容是中文
是否為當初安裝時語系沒有選好?

2007/7/3 23:56
應用擴展 工具箱
回復: 安裝gcin遇到的問題
回復: 安裝gcin遇到的問題
Anon:回復: 安裝gcin遇到的問題
Ubuntu 7.04 本身就有 gcin 1.3.3-1,直接用 synaptic 安裝就好了。

據我了解 7.04 預設就有啟用 universe 才對,如果你找不到 gcin,可能是 universe 沒打開。編輯 /etc/apt/sources.list 啟用 universe 就能安裝 gcin 1.3.3-1

2007/7/4 0:51 | 77ea3 6d875 4ab4d 7d8b7
應用擴展 工具箱
訪客
回復: 安裝gcin遇到的問題
Anon:訪客
以編譯的方式安裝,比較麻煩,建議直接抓deb來安裝。
另在在gcin上有看到說明,在,/configure會有錯誤,不過不會影響後續的make和make install,如果勇氣夠的話(我是不夠啦!我用的是dabian的1.3.5.pre2), 可以繼續編譯安裝。

2007/7/4 9:44 | e95ee cae4e 79a8a f9436
應用擴展 工具箱
回復: 安裝gcin遇到的問題

註冊日期:
2007/7/3 14:49
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
有試過裝gcin 1.3.3的deb檔
也是失敗
錯誤訊息,晚上再貼上來

新手不知道要怎麼開啟Universe?
查了一下資料,知道apt分成Main、Restricted、Universe' Multiverse,但是不知道要怎麼在Source.list中使用?

2007/7/4 12:59
應用擴展 工具箱
回復: 安裝gcin遇到的問題
會員五級
註冊日期:
2007/1/15 14:06
所屬群組:
已註冊使用者
等級: 29
HP : 0 / 705
MP : 369 / 32768
EXP: 20
離線
如果先前已裝了無法使用的gcin: sudo apt-get remove gcin

先不要亂改/etc/apt/sources.list

也先不要自己下.deb回來裝

至-系統-管理-Synaptic
按-設定-套件庫
第1頁全部打勾

關閉設定,

按-重新載入
按-搜尋: gcin

選中-標記為安裝-套用

如果已經打勾的話, 就選 "重新安裝"

2007/7/4 13:10
新手安裝完第一件事:灌Ubuntu懶人包就對啦!
新手安裝完第二件事:,欲觀看請指向這裡。
應用擴展 工具箱

(1) 2 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.