在 ubuntu 安裝 kate 的問題? [論壇 - Ubuntu 與工具程式及軟體推薦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



在 ubuntu 安裝 kate 的問題?
會員三級
註冊日期:
2011/7/31 15:17
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 238
MP : 44 / 7117
EXP: 53
離線
在 ubuntu 透過 apt-get 安裝 kate 只有英文版?「虛設」的終端機?
在 ubuntu 透過 synaptic 安裝 muon 只有英文版?透過 muon 安裝 kate 也只有英文版?
在 ezgoX 安裝的 ezgo 10,安裝的 kate 是中文版, 終端機也可用。
我最先的 kate (英文版)是伴隨著 Gnome 環境而來的??

請問如何在 ubuntu 安裝 kate 中文版?要在 kubuntu 環境嗎?

2012/11/3 0:56
應用擴展 工具箱
回覆: 在 ubuntu 安裝 kate 的問題?
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 33625
EXP: 38
離線
安裝相對應的語系軟體包應該就可以了
至少我的 ubuntu 現在是中文的

2012/11/3 1:29
應用擴展 工具箱
回覆: 在 ubuntu 安裝 kate 的問題?

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 60904
EXP: 24
離線
請問如何在 ubuntu 安裝 kate 中文版?要在 kubuntu 環境嗎?

kate 是在 kde 圖形界面 使用
kde 界面的 中文界面 是 language-selector-kde 來安裝
sudo apt-get install language-selector-kde

進一步參考

1. 在 Ubuntu 安裝 最新版 KDE SC 4.9
登出 重新登入 選擇 KDE Plasma Workspace 即是 kubuntu-desktop 桌面

2. 在 Kubuntu 安裝 中文界面
2-1. mini ubuntu for kde繁中化的問題
2-2. Mini Kubuntu安裝經驗分享

3. 執行完 1, 2 Kate 應該就會有 中文界面

2012/11/3 7:37
應用擴展 工具箱
回覆: 在 ubuntu 安裝 kate 的問題?
會員三級
註冊日期:
2011/7/31 15:17
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 238
MP : 44 / 7117
EXP: 53
離線
非常感謝 Vdragon 和 poloshiao 的分享,謝謝。

2012/11/3 13:03
應用擴展 工具箱
回覆: 在 ubuntu 安裝 kate 的問題?
會員三級
註冊日期:
2011/7/31 15:17
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 238
MP : 44 / 7117
EXP: 53
離線
偶突然想到,基於類似像中文環境,我就安裝了 konsole 的終端機軟體,kate 裡的終端機立刻可用。(如果正在使用 kate 的話,所有都存檔後,先關閉 kate 後再進入 kate 即可)

2012/11/9 1:11
應用擴展 工具箱
回覆: 在 ubuntu 安裝 kate 的問題?
管理員
註冊日期:
2012/1/14 18:41
所屬群組:
討論區管理群
等級: 20
HP : 0 / 480
MP : 159 / 13715
EXP: 23
離線
language-selector-kde 這個套件再12.10好像背放棄了
我既得作者有說不建議安裝這個套件了。
似乎他在12.10已經沒有更新了,會說他少了一些東西。目前還找不到解決辦法。

2012/11/9 10:01
應用擴展 工具箱
回覆: 在 ubuntu 安裝 kate 的問題?

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 60904
EXP: 24
離線
language-selector-kde 這個套件再12.10好像背放棄了
我既得作者有說不建議安裝這個套件了。
似乎他在12.10已經沒有更新了,會說他少了一些東西。目前還找不到解決辦法。


1. “language-selector-kde” binary package in Ubuntu Quantal i386

This package let you change and install language packs in Kubuntu.
This package contains the KDE frontend.

2012-10-09... Ubuntu Quantal i386 ... release universe admin 0.89
Removed from disk on 2012-10-10.
Removal requested on 2012-10-10.
Superseded on 2012-10-09 by i386 build of language-selector 0.90 in ubuntu quantal RELEASE
Published on 2012-09-27

所以 language-selector-kde 由 language-selector 取代
language-selector-kde 從 main 套件庫 移到 universe 套件庫
ISO 裏沒有包入 language-selector-kde
Live DVD 裏面沒有 language-selector-kde
要安裝 language-selector-kde 需要 把 universe 打勾

2012-10-09 還出 更新版本
2012-10-09 ... Published Ubuntu Quantal i386 release universe admin 0.90

2. “language-selector” binary package in Ubuntu Quantal i386

Publishing history
2012-07-02 ... Deleted ... Ubuntu Quantal i386 release universe admin 0.81
所以 language-selector 套件 實際上 在 Kubuntu 12.10 不存在了

3. Kubuntu 12.10 預設只有安裝

language-selector-common : Language selector for Ubuntu
This package let you change and install language packs in Ubuntu.
This package contains the common part of language-selector

只有指令
/usr/bin/check-language-support

4. 這麼看來 Kubuntu 的使用者 可能要 自己使用指令 安裝 語言套件了

4-1. 安裝 kubuntu 繁體中文套件
sudo apt-get install language-pack-kde-zh-hant
會同時安裝 相依套件
language-pack-zh-hant
language-pack-zh-hant-base

4-2. 安裝 firefox 繁體中文套件
sudo apt-get install firefox-locale-zh-hant

4-3. 安裝 thunderbird 繁體中文套件
sudo apt-get install thunderbird-locale-zh-hant

4-4. 在 /etc/default/locale 設定 locale 預設爲 zh_TW.UTF-8

4-5. 在 ~/.bashrc 或 其它適當的 設定檔 設定 locale 預設爲 zh_TW.UTF-8

2012/11/9 11:09
應用擴展 工具箱
回覆: 在 ubuntu 安裝 kate 的問題?
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 33625
EXP: 38
離線
poloshiao 寫到:
check-language-support

感謝分享

2012/11/9 12:22
應用擴展 工具箱
回覆: 在 ubuntu 安裝 kate 的問題?

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 60904
EXP: 24
離線
我就安裝了 konsole 的終端機軟體,kate 裡的終端機立刻可用。


0. 安裝 apt-rdepends 套件
sudo apt-get install apt-rdepends # universe 需打勾

1. 看看 konsole 跟 language-selector-common 有沒有關係
sudo apt-rdepends konsole | grep language-selector-common
Depends: language-selector-common
原來 language-selector-common 是 konsole 的相依套件
安裝 konsole 時 如果 language-selector-common 還沒安裝或設定 會一起 安裝或設定

2. 看看 kate 跟 language-selector-common 有沒有關係
sudo apt-rdepends kate | grep language-selector-common
Depends: language-selector-common
原來 language-selector-common 是 kate 的相依套件
安裝 kate 時 如果 language-selector-common 還沒安裝或設定 會一起 安裝或設定

3. language-selector-common 是 安裝 Kubuntu 時就 預裝了

4. 所以 設定 中文環境 與 安裝 konsole 與 kate 的先後 應該沒有關係

5. 從 軟體來源 / 相依套件 可以看出
konsole 是 kate 的 建議安裝套件
換句話說
安裝 kate 之後 建議 安裝 konsole
可以看出 兩者 先後安裝順序

2012/11/9 12:35
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.