Ubuntu 6.06 Dapper 要如何更新到最新版的Apache 跟 PHP [論壇 - 伺服器架設]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



Ubuntu 6.06 Dapper 要如何更新到最新版的Apache 跟 PHP
會員一級
註冊日期:
2006/6/10 13:51
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 0
MP : 0 / 31
EXP: 2
離線
有一台 Ubuntu 6.06 的 Server
最近被學校計算機中心警告說有安全性漏洞
要將Apache2及PHP5更新
但是用apt-get upgrade都找不到最新版的apache2跟php5

請問有方法透過apt安裝到最新版本嗎?
如果從網站抓原始碼回來安裝,會不會造成以後apt出錯呢?

謝謝

2008/3/19 21:37
應用擴展 工具箱
回復: Ubuntu 6.06 Dapper 要如何更新到最新版的Apache 跟 PHP
會員一級
註冊日期:
2006/7/20 23:37
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 0
MP : 0 / 30
EXP: 2
離線
我也遇到同樣的問題,我犯了一個錯誤,就是直接升級。
我建議你先仔細的將各種資料備份好,再做處理,尤其資料庫,
不要用複製 /var/lib/mysql/ 底下的,先參考這分文件
http://so-ga.com/Discuz!/archiver/?tid-382102.html

其他的目錄如:/var/www, /home/ 這是比較重要的幾個。

我現在也正在想辦法回覆我升級錯誤的主機。你有什麼收穫,記得告訴我一聲!

2008/3/24 9:05
應用擴展 工具箱
回復: Ubuntu 6.06 Dapper 要如何更新到最新版的Apache 跟 PHP
會員三級
註冊日期:
2007/8/9 10:42
所屬群組:
已註冊使用者
等級: 14
HP : 0 / 346
MP : 84 / 14626
EXP: 84
離線
當然可以從原始碼安裝 - 只要你先把用apt 安裝的版本移除

p.s.: 這是樓上的回覆

我也遇到同樣的問題,我犯了一個錯誤,就是直接升級。 我建議你先仔細的將各種資料備份好,再做處理,尤其資料庫, 不要用複製 /var/lib/mysql/ 底下的,先參考這分文件 http://so-ga.com/Discuz!/archiver/?tid-382102.html 其他的目錄如:/var/www, /home/ 這是比較重要的幾個。 我現在也正在想辦法回覆我升級錯誤的主機。你有什麼收穫,記得告訴我一聲!

2008/3/24 10:30
Winning, by not competing at all
應用擴展 工具箱
回復: Ubuntu 6.06 Dapper 要如何更新到最新版的Apache 跟 PHP
會員一級
註冊日期:
2006/6/10 13:51
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 0
MP : 0 / 31
EXP: 2
離線
不知道二樓的直接升級是指從原始碼編譯嗎?
還是把source.lists換成新版的然後用apt-get?
因為看到你問的那篇,有人回應有兩種方法
http://www.ubuntu.org.tw/modules/newbb/viewtopic.php?post_id=40759#forumpost40759
不知道你是用哪一種?

另外我有找到一個將原始碼包成ubuntu用的deb
只是我還沒試過,不知道這個方法會不會好一點
https://answers.launchpad.net/ubuntu/+question/4312

2008/3/28 18:55
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.