pluma顯示亂碼 [論壇 - LinuxMint]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



pluma顯示亂碼
會員三級
註冊日期:
2008/4/26 1:28
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 251
MP : 48 / 8488
EXP: 5
離線
linuxmint mate14.04開啟字幕檔時顯示亂碼,好像沒人有這問題?

2014/12/16 10:52
應用擴展 工具箱
回覆: pluma顯示亂碼
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 35
HP : 170 / 850
MP : 580 / 18809
EXP: 3
離線
ramble77 寫到:
linuxmint mate14.04開啟字幕檔時顯示亂碼,好像沒人有這問題?



給你幾個線索找到解決方案。

1.你開的字幕檔,猜測應該是big5編碼。
2.pluma源自於gedit
3.所以應該可以參考「這篇」來解決你的問題。

PS:以上純屬推論,沒有實際去測試過是否可行(pluma)。


2014/12/16 12:43
應用擴展 工具箱
回覆: pluma顯示亂碼
會員五級
註冊日期:
2009/10/29 4:50
所屬群組:
已註冊使用者
等級: 41
HP : 201 / 1009
MP : 898 / 29629
EXP: 36
離線
samwhelp 寫到:

給你幾個線索找到解決方案。

1.你開的字幕檔,猜測應該是big5編碼。
2.pluma源自於gedit
3.所以應該可以參考「這篇」來解決你的問題。

PS:以上純屬推論,沒有實際去測試過是否可行(pluma)。



那個只能解決gedit的正體中文亂碼問題喔。
pluma的解決指令是底下這個:
gsettings set org.mate.pluma auto-detected-encodings "['UTF-8', 'BIG5', 'BIG5-HKSCS', 'EUC-TW', 'CURRENT', 'ISO-8859-15', 'UTF-16']"

2014/12/16 13:06
應用擴展 工具箱
回覆: pluma顯示亂碼
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 35
HP : 170 / 850
MP : 580 / 18809
EXP: 3
離線
1. 若不排斥的話,也可以使用「kate」這個「編輯器」。
基本不用設定,就可以分辨編碼,儲存時,也可以儲存成不同的編碼。
這是我個人的使用習慣,只是額外提供一個選項。

``` sh
sudo apt-get install kate
```


2. 另外關於文字檔編碼的問題,可以參考下面幾篇討論串。

* Geany 的 使用心得
* 解壓縮zip檔,產生亂碼,如何解決的心得


3. 另外若是vlc或是smplayer的字幕,都有可以設定檢測字幕編碼的選項。

vlc:

「Tools/Preferences/Subtitles-OSD/Subtitle Language」

smplayer:

「Options/Preferences/Subtitles/Encoding」

2014/12/16 13:40
應用擴展 工具箱
回覆: pluma顯示亂碼
會員三級
註冊日期:
2008/4/26 1:28
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 251
MP : 48 / 8488
EXP: 5
離線
用了三樓大大的:
gsettings set org.mate.pluma auto-detected-encodings "['UTF-8', 'BIG5', 'BIG5-HKSCS', 'EUC-TW', 'CURRENT', 'ISO-8859-15', 'UTF-16']"
ok了。真多謝!

2014/12/16 18:59
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.