星球 - USN-3065-1: Libgcrypt vulnerability

來自:Ubuntu security notices | 2016/8/20 13:31:51

Ubuntu Security Notice USN-3065-1


18th August, 2016


libgcrypt11, libgcrypt20 vulnerability


A security issue affects these releases of Ubuntu and its
derivatives:




  • Ubuntu 16.04 LTS


  • Ubuntu 14.04 LTS


  • Ubuntu 12.04 LTS





Summary


Libgcrypt incorrectly generated random numbers.





Software description





  • libgcrypt11
    - LGPL Crypto library







  • libgcrypt20
    - LGPL Crypto library







Details


Felix Dörre and Vladimir Klebanov discovered that Libgcrypt incorrectly
handled mixing functions in the random number generator. An attacker able
to obtain 4640 bits from the RNG can trivially predict the next 160 bits of
output.



Update instructions


The problem can be corrected by updating your system to the following
package version:




Ubuntu 16.04 LTS:




libgcrypt20

1.6.5-2ubuntu0.2





Ubuntu 14.04 LTS:




libgcrypt11

1.5.3-2ubuntu4.4





Ubuntu 12.04 LTS:




libgcrypt11

1.5.0-3ubuntu0.6






To update your system, please follow these instructions:
https://wiki.ubuntu.com/Security/Upgrades.


In general, a standard system update will make all the necessary changes.





References




CVE-2016-6313